Com instalar Python 3.0 a Debian Lenny

Com ja sabreu fa uns dies va sortir sa nova versió del llenguatge Python 3.0. Aquesta versió ha estat renovada amb profunditat, tant que fins i tot és incompatible amb la branca 2.x. Això no lleva que aquesta darrera branca no estigui suportada per llarg temps, de fet, avui mateix ha sortit sa primera versió de correcció de la 2.6 que vé a ser una versió de comptabilitat entre la 2.5 i la 3.0.

Si voleu veure totes les novetats que hi ha heu d’anar a What’s New in Python 3.0?

Anem a lo interessant: Instal·lació a Debian Lenny.

  1. Baixar-nos el programa des d’aqui.
  2. Descomprimir-ho a una carpeta: tar -jvxf  Python-3.0.tar.bz2
  3. Ara ve es BUG inesperat que com tot té solució:

S’han d’editar dos arxius: setup.py i Modules/_dbmmodule.c i s’els ha d’aplicar aquest diff per a que es puguin compilar tots els moduls. Perquè sino falla al compilar (make) el mòdul _dbm.

./configure –with-pydebug –with-doc-strings –enable-shared –enable-ipv6 –enable-profiling –with-threads –with-tsc (això ja va a gust del consumidor)

make

Per acabar, si se vol, se fa un make install (pero no importa per fer proves).

Llest!, ja podem provar es Python 3.0 sense haver d’esperar es paquetet deb ,que ens hem tornat massa vagos alhora de compilar aplicacions, al meny jo un poc si🙂

Quant a vtomasr5
Linuxero

Deixa un comentari

Fill in your details below or click an icon to log in:

WordPress.com Logo

Esteu comentant fent servir el compte WordPress.com. Log Out / Canvia )

Twitter picture

Esteu comentant fent servir el compte Twitter. Log Out / Canvia )

Facebook photo

Esteu comentant fent servir el compte Facebook. Log Out / Canvia )

Google+ photo

Esteu comentant fent servir el compte Google+. Log Out / Canvia )

Connecting to %s

%d bloggers like this: